this post was submitted on 15 Oct 2023
303 points (95.2% liked)

Programmer Humor

31812 readers
548 users here now

Post funny things about programming here! (Or just rant about your favourite programming language.)

Rules:

founded 5 years ago
MODERATORS
 
all 31 comments
sorted by: hot top controversial new old
[–] Gentoo1337 47 points 10 months ago (3 children)

I remember one GitHub project that implemented some algorithm (I think it was Dijkstra's) but only used 4 or 5 single letter variables and just kept reusing them.

[–] [email protected] 37 points 10 months ago (2 children)

When I was in college, I had a guy that I was working on a project with that did this constantly. At one point I looked at one of his files and the variables were named a, b, c, aa, ab, ac, ba, bb, etc. That when I was like, bro, you gotta stop doing this.

[–] [email protected] 41 points 10 months ago

"Inside you there are two wolves..." or something:

Option 1: Sit down with them and go line by line through it. Make him identify each variable's purpose and then immediately find and replace to rename every instance with a more descriptive name.

Option 2: Small script to shuffle the variable names in his code around after each of his commits.

[–] [email protected] 4 points 10 months ago

The guy thinks in Excel.

[–] [email protected] 8 points 10 months ago (1 children)

When you are used to math equations, it's easy to slip into that habit.

[–] [email protected] 7 points 10 months ago (2 children)

Single letter variables, yes. Reusing them? No.

[–] [email protected] 4 points 10 months ago (1 children)

Only if they are well-known in the language you’re using or domain you’re writing for. x and y are fine for coordinates. i and j are fine for loop indices. But abbreviating things unnecessarily is bad IMO. s = GetSession() is too terse, for example.

[–] [email protected] 3 points 10 months ago

No, I mean single-letter vars are standard in physics and math, but reusing vars is not acceptable. Obviously they're not good practice except in the scenarios you describe, but mathies gonna math.

[–] [email protected] 6 points 10 months ago* (last edited 10 months ago)

Maybe they had a background in low-level assembly code? If you're writing assembly that's kinda sorta how you'd handle registers.

[–] [email protected] 30 points 10 months ago (1 children)

"result" is fine. That is the variable you will end up returning that you have to fill with stuff first.

"data" on the other hand…

[–] [email protected] 5 points 10 months ago

I came here to say this.

Declare result in the first line of the function and return result is the last line. In C++, this is a big hint to the compiler that you want return value optimization to kick in.

[–] [email protected] 25 points 10 months ago (1 children)

As a person who victimizes coworkers like this, I apologize. Thank you for pointing it out, and I will stop doing it.

[–] [email protected] 12 points 10 months ago (1 children)

Be proud that it's a step up from var x

Be scared that your coworkers are planning how to best apply the baseball bat to your knees anyway

[–] [email protected] 2 points 10 months ago

Even using absolute best prackies, developers are gonna find a bunch of stuff to complain about.

[–] [email protected] 21 points 10 months ago (1 children)

Well obviously it's the result of some algorithm that will happen.

[–] [email protected] 8 points 10 months ago (1 children)
[–] [email protected] 1 points 9 months ago

Will name every of my functions like this now, thank you for pointing out that incredible meaningful name

[–] [email protected] 19 points 10 months ago

I've had instances where I worked with an API so badly designed in a dynamic language that I had no idea what I might receive.

This, when I get something back that's not what I expected, I just logged the type because I really don't know what it is. It's the result. Whatever that means.

[–] [email protected] 15 points 10 months ago (1 children)

It could be that this is a habit left over from pascal, where result is a reserved word, and is automatically made the return value of the function.

If it is in the context of a short function, I don't see that it's all that bad.

[–] [email protected] 4 points 10 months ago

Yup, I also do that. If I just need a variable to put in what will be returned, I call it result. What it means should be clear from the function name. Repeating that feels redundant.

[–] [email protected] 7 points 10 months ago (1 children)
[–] [email protected] 7 points 10 months ago (2 children)

Exactly. If it's a statically typed language and the function has a clear name? I know what type it is, I know what it's for, I'm good.

There are far worse sins, like intermediate variables or worse, public class members named "obj" or "data".

[–] [email protected] 1 points 10 months ago

GitHub doesn’t show types. So if the value is given to another function you would have no way of knowing what type it is unless you read the file that other function is declared in.

[–] [email protected] 3 points 10 months ago (1 children)

As someone who uses 'result' as a variable name in functions all the time, please tell me what you think is wrong with it?

If a function is called for example 'transformAtoB' it should be totally obvious what the variable will contain.

[–] [email protected] 1 points 10 months ago* (last edited 10 months ago)

It’s not necessarily bad, it just provides very little information.

[–] [email protected] 2 points 10 months ago* (last edited 10 months ago)

You declare it as the first line after "function getNextDay() : date {", then it is glaringly obvious that is a date variable that will (eventually) contain tomorrow's date, and will be returned by the function.

However, I would only use "var" if it's initialized in the same statement. It prevents Smurf code, and the compiler knows the type straight away.

Given a small and clean context, variable names don't need to be specific.

[–] [email protected] 2 points 10 months ago

The only issue is "var".

[–] [email protected] 0 points 10 months ago

yah because we’d rather die than use return type hints.