this post was submitted on 01 Sep 2023
329 points (96.1% liked)

Programming

17123 readers
171 users here now

Welcome to the main community in programming.dev! Feel free to post anything relating to programming here!

Cross posting is strongly encouraged in the instance. If you feel your post or another person's post makes sense in another community cross post into it.

Hope you enjoy the instance!

Rules

Rules

  • Follow the programming.dev instance rules
  • Keep content related to programming in some way
  • If you're posting long videos try to add in some form of tldr for those who don't want to watch videos

Wormhole

Follow the wormhole through a path of communities [email protected]



founded 1 year ago
MODERATORS
you are viewing a single comment's thread
view the rest of the comments
[–] [email protected] 51 points 1 year ago* (last edited 1 year ago) (4 children)

This is the only way;

if (condition) {
    code
}

Not

if (condition)
{
    code
}

Also because of my dyslexia I prefer variable & function names like this; 'File_Acces' I find it easier to read than 'fileAcces'

[–] TopRamenBinLaden 5 points 1 year ago (1 children)

I think it would be a much hotter take if you had the opposite opinion. I've only met a few of those.

[–] [email protected] 2 points 1 year ago (2 children)

I'm not a programmer (I tried learning programming and unity but got lazy so....) but when I learned about if-then statements, the second one seemed like the way it's supposed to be; I mean it looks so clean and simple. Do actual programmers prefer the first method?

[–] [email protected] 4 points 1 year ago

I prefer the first method because it reduces the number of empty lines I have to scroll past and visually filter out

[–] [email protected] 2 points 1 year ago

The 2nd is the style guide used in C#, and therefore what you've encountered in unity.

[–] [email protected] 4 points 1 year ago* (last edited 1 year ago) (1 children)

I've only seen the second type in C#, to be fair it makes code neater but i'm glad I left it for Java.

[–] [email protected] 2 points 1 year ago

How does it make code neater? All it does is add a ton of empty vertical space. It makes files arbitrarily longer at essentially no benefit.

[–] [email protected] 3 points 1 year ago (1 children)

It depends for me. If the condition is some goofy ahh multiline syntax hell i like to use the second option.

[–] mindbleach 2 points 1 year ago

Even then - ) { on a newline.

[–] [email protected] 2 points 1 year ago* (last edited 1 year ago)

I use all 3.

If it's very short and there's 2 or more in a row, I'll put it all in one line.

If there's a bunch of nested if statements, I'll use the second.

If neither of those conditons, I'll use the first.